ComboBox ficando vazia

Olá,
A situação é a seguinte:
Tenho várias combobox onde escolho um dos item na mesma e uma variável recebe um valor correspondente.
A mesma variável é conectada ao Value da combobox para que o valor escrito na combobox mude conforme a tal variável (pois pode ser que esse valor seja modificado por outros meios e preciso que a escrita na combobox seja atualizada ).
Acontece que quando o valor é atualizado externamente ao supervisório a combobox fica vazia…
obs.: estou monitorando o valor da variável propriamente e este está correto sempre.

Obrigado

Problema encontrado.

É o Clear() no onstartruning() que apaga o value do combobox.
Mas não deveria a tag conectada ao Value modificar o combobox depois do onstartruning() event?

Paulo,

A conexão é do tipo bidirecional? A Tag conectada está no Servidor? Poderia enviar um print da associação?

Oi Paulo.
Seguinte, resolvido sim o problema, porém por script.
Eu nao estou mais utilizando somente a associação no Value da combobox mas também o mesmo “Value = ‘ao que deve ser mostrado’” depois do clear() no onStartRunning.

Isso resolveu meu problema, porém não sei se foi a maneira ideal.

desculpe não ter enviado antes.

O script que resolveu:
Sub ComboBox2_OnStartRunning()
Clear()
set ciclo = Application.GetObject(“Dados.TAE1.[TAE1-Ciclo]”)
if ciclo.SptFuncCiclo1 = 0 then
Value = “MISTURA”
elseif ciclo.SptFuncCiclo1 = 1 then
Value = “AERAÇÃO”
elseif ciclo.SptFuncCiclo1 = 2 then
Value = “SEDIMENTAÇÃO / ESTÁTICO”
elseif ciclo.SptFuncCiclo1 = 3 then
Value = “RETIRADA de CLARIFICADO”
end if

AddItem "MISTURA" 					'0'
AddItem "AERAÇÃO" 					'1'
AddItem "SEDIMENTAÇÃO / ESTÁTICO"      '2'
AddItem "RETIRADA de CLARIFICADO"	'3'	

End Sub