Tags OPC não comunicam

Boa tarde, pessoal. Peguei uma aplicação de um computador que tem alguns tags OPC funcionando bem, porém quando rodo a aplicação em outro computador os tags não comunicam, estando na mesma rede. É preciso fazer alguma configuração adicional que dependa do computador utilizado para que possa comunicar ? Agradeço a força!

Abraço.

1 Like

@kelvin
Aplique o Elipse DCOM Wizard no computador e verifique o comportamento. Ele está disponível para download em:
https://www.elipse.com.br/downloads/?key=Elipse+DCOM+Wizard&language=ptbr

1 Like

Ok. Mas é preciso instalar um OPC client na máquina?

1 Like

Oi Kelvin, Bom dia!

Pelo que entendi, a aplicação que está utilizando em outro computador possui tags OPC, logo ela deve ser a aplicação OPC Cliente.

O que pode ocorrer é o computador que esta com o OPC Server, não ter permissão para esta nova máquina/usuário de rede se conectar a ele.

Recomendo que verifica as permissões de firewall e dcom no computador do OPC Server.

Att,
Marco Antonio

1 Like

@kelvin
O E3 é um cliente OPC nativo. Veja mais detalhes no artigo:
http://kb.elipse.com.br/pt-br/questions/30 - Configurando o Elipse E3 como cliente OPC.

1 Like

Olá, pessoal. Esqueci de mencionar que se trata do Scada. Além do OPC há também o AltusTCPIP rodando na aplicação. Os tags do driver TCPIP são lidos normalmente, no entanto os do OPC não.

1 Like

@kelvin
Sobre o SCADA como cliente OPC:
http://kb.elipse.com.br/pt-br/questions/45 - Configurando o Elipse SCADA como cliente OPC.

Utilize o DCOM Wizard para realizar as configurações referentes ao Elipse SCADA, em ambos computadores:

1 Like

Essa é a configuração da aplicação que eu peguei. Porém no meu computador os tags OPC não comunicam.

1 Like

Quando aplico o Elipse Scada no Elipse DCOM Wizard aparecem as informações acima.

1 Like

@kelvin
Após aplicar o Elipse DCOM Wizard, esta é a janela esperada:

Você enviou um printscreen do Elipse OPC Client:
O erro 80004005 mostrado no log é um erro genérico de conexão, provavelmente devido à indisponibilidade de seu servidor OPC. Verifique se o mesmo está rodando corretamente e configurado para acesso externo.

Caso tenha executado corretamente o Elipse DCOM Wizard (para o Elipse SCADA e para o Elipse OPC Client, como mostrou no printscreen):

  • Qual é a versão utilizada do CodeSys?
  • Qual é o sistema operacional utilizado atualmente? Qual era o sistema operacional utilizado no antigo computador?
  • Qual é a versão do SCADA instalado?
1 Like

A versão do CodeSys não consegui encontrar, porém o meu sistema operacional é Windows10. A versão do Scada é 2.29 b151. Executei o DCOM Wizard para o Scada e cliente mas não adiantou . quando clico em versão ele diz que a inicialização do OPC falhou. Onde encontro a versão do CodeSys?
O servidor OPC é um CLP Nexto, da Altus. Acredito que está configurado corretamente pois o computador de onde peguei a aplicação lê os dados OPC normalmente.

1 Like

@kelvin
Sugiro verificar com o fabricante do servidor OPC qual é a versão utilizada, bem como se ela é compatível com o Windows 10 e se há alguma configuração extra a ser feita para que clientes possam acessá-lo neste sistema operacional. Da parte do Elipse SCADA, o DCOM Wizard realiza as configurações necessárias.

Também ficou faltando:

  • Qual era o sistema operacional utilizado no antigo computador?
1 Like

Olá. O computador da operação também é Windows10. O suporte da altus me informou que preciso configurar o programa no computador que vai ser o cliente. Vou tentar fazer isso e retorno. Muito obrigado!
Vocês do suporte têm número do wathsapp para tirar dúvidas mais pontuais? facilita bastante.

1 Like

@kelvin
As formas de contato são por email, fórum, skype ou telefone.

  • Para integradores/fabricantes de máquinas/instituições de ensino é necessário ter treinamento do produto para acesso ao suporte.
  • Para clientes finais, é necessário possuir o Elipse Care adicionado à respectiva licença para atendimento via telefone.

Veja também:


http://kb.elipse.com.br/

1 Like

Bom dia, pessoal. Consegui comunicar. Era uma configuração faltando no servidor.
Agradeço a força,

Abraço.

1 Like

Bom dia, estou com um problema parecido.

No meu caso, consigo comunicar com o PLC quando estou na área de desenvolvimento e testo a comunicação. Consigo Ler e Escrever normalmente.
Agora quando rodo a aplicação os valores não atualizam com o PLC. Alguns TAGs resolveram quando habilitei na área de propriedades, o parâmetro “Habilita escrita automática”. Mas a maioria não.

1 Like

Você já usou o Elipse DCOM Wizard?

Veja mais detalhes em: http://kb.elipse.com.br/pt-br/questions/4139

1 Like

Olá @Pedro_Bonfim!

Você conseguiu resolver o problema?

1 Like

@pgustavo Ainda não. No momento estou trabalhando no programa do PLC. Quando retornar ao Supervisório vou realizar verificar com mais calma e seguir a indicação d Elipse DCOM. Não cheguei a executa-lo.

Att,
Pedro

1 Like

Problema resolvido. Foi necessário habilitar uma função do PLC.

1 Like